WordPressの一覧に戻る

脆弱性の詳細

Divi Form Builder:コード実行

WordPress プラグインCVE-2026-5524重要度:深刻悪用状況:未確認修正版:要確認

Divi Form Builderを使っている方が確認する情報です。公表文は「コード実行」に関する問題を示しています。公開された対象範囲を下に日本語で示しています。

危険と対策

取得データを決まったルールで整理した条件と、製品ごとの確認手順です。 保存済みの詳しい解説がないため、取得できた条件と共通の確認手順を表示しています。

どんな危険?

問題の種類についての一般的な説明:攻撃が成立すると、攻撃者が対象のサーバーや機器に命令を実行させるおそれがあります。データの読み取り・改ざんや、サービスの乗っ取りにつながり得る種類の問題です。

自分は対象?

  • 最初に「Divi Form Builder」を使っているか、開発元・製品名・バージョンを確認します。同じカテゴリの製品を使っているだけでは、この問題の対象とは限りません。

    自分の環境で確認根拠 1根拠 2根拠 3
  • 公開データの対象範囲:Divi Form Builder — 5.1.8以下。この範囲に加え、下に記載する権限・構成などの条件も照合してください。

    公表された条件根拠 1根拠 2根拠 3
  • 公表されたCVSS評価では、攻撃前に対象システムの権限を持っている必要はありません。他の構成・機能の条件まで不要という意味ではありません。

    公表された条件根拠 1根拠 2根拠 3根拠 4
  • 公表されたCVSS評価では、ネットワーク越しに攻撃が届く経路があります。あなたの環境がインターネットから到達可能かどうかは、公開設定を別に確認する必要があります。

    公表された条件根拠 1根拠 2根拠 3根拠 4
  • 公表されたCVSS評価では、攻撃者以外の利用者がリンクを開くなどの操作をしなくても、攻撃が成立し得ます。

    公表された条件根拠 1根拠 2根拠 3根拠 4
対象の版
Divi Form Builder:5.1.8以下
修正版
このデータでは未確認。更新が提供されていない、という意味ではありません。

どうすればいい?

  1. 「CVE-2026-5524」と現在の版を管理担当者・提供元へ伝え、この問題に対応した修正版が提供されているか確認します。下の問い合わせ文に記入すれば、そのまま依頼できます。対象範囲の上限から修正版の番号を推測しないでください。

    一般的な作業手順根拠 1根拠 2根拠 3
  2. ファイルとデータベースのバックアップを取り、管理画面の「ダッシュボード」→「更新」で該当プラグインの更新を実行します。更新が表示されない有料製品などは、購入先・開発元の正規の配布経路を利用してください。

    一般的な作業手順根拠 7根拠 8根拠 9

使っているバージョンの調べ方

  1. WordPressの管理画面にログインし、「プラグイン」→「インストール済みプラグイン」を開きます。「Divi Form Builder」と同じ製品名・開発元の項目を探し、表示されているバージョンを控えてください。停止中のプラグインも一覧に含めて確認します。

    一般的な作業手順根拠 5
  2. 管理画面に入れない、または同じ名前の製品を判別できない場合は、下の問い合わせ文をサイトの制作会社・管理担当者に送ってください。名前が見つからないという理由だけで、安全とは判定しないでください。

    一般的な作業手順根拠 6根拠 5

すぐに更新できないとき

  • 更新できない場合は、対象機能の停止や公開範囲の制限が使えるかを管理担当者と検討し、実施内容と更新予定日を記録してください。プラグインの「無効化」だけでこの脆弱性を防げるかは個別に確認が必要です。

    一般的な作業手順根拠 5根拠 1根拠 2根拠 3

対応が終わったら確認すること

  1. 更新後に同じ管理画面を開き直してバージョンを記録します。修正対象の系列・版と一致するかを照合し、サイト表示、ログイン、フォームや購入など普段使う主要な操作も確認してください。更新ボタンを押しただけでは完了としないでください。

    一般的な作業手順根拠 7根拠 8

まだ分からないこと・判断の限界

  • 取り込んだ公開データには、修正済みと明記されたバージョン番号がありません。「修正されていない」と確定したわけではありません。下の問い合わせ文で、修正版の番号・提供場所・適用予定を確認できます。
  • AIによる全文翻訳は行っていません。公式の構造化データを決まったルールで日本語表示し、製品ごとの一般的な確認・更新手順を補足しています。本文だけに記された対象条件や例外は、併記した原文・根拠と照合してください。

管理会社・担当者に聞くための確認メモ

自分で操作できない場合に使えます。コピー先で空欄を埋めて担当者へ送ってください。

この解説・手順の根拠

  1. NVDの原文
  2. security@wordfence.com
  3. security@wordfence.com
  4. FIRST公式:CVSS 3.1の条件の定義
  5. WordPress公式:プラグイン一覧
  6. WordPress公式:サイトヘルスの情報
  7. WordPress公式:本体の更新
  8. WordPress公式:更新画面
  9. WordPress公式:プラグインの確認と更新
  10. 公式記録の識別番号

説明に対応する原文の抜粋

日本語の説明の根拠になった、取得済みの公式情報です。各抜粋を開くと、出典と元の文章を確認できます。

  1. 抜粋 1:www.cve.org
    The Divi Form Builder plugin for WordPress is vulnerable to Arbitrary File Upload leading to Remote Code Execution in all versions up to and including 5.1.8. This is due to insufficient file extension validation in the do_image_upload() function where user-supplied input from the acceptFileTypes POST parameter is directly interpolated into a regular expression used to validate uploaded files. Attackers can specify PHP-executable extensions such as .phtml, .phar, .php5, or .php7 to bypass the plugin's .htaccess protection which only blocks .php files specifically. Additionally, on Nginx-based servers, the .htaccess protection is completely ineffective as Nginx does not process .htaccess files. This makes it possible for unauthenticated attackers (who can obtain a nonce from any public page containing a form) to upload executable PHP files to the publicly accessible /wp-content/uploads/de_fb_uploads/ directory and achieve Remote Code Execution by accessing the uploaded file via HTTP. The vulnerability was partially patched in version 5.1.3.
    この抜粋の出典を開く

    取得元の項目:/originalText / 言語:und

  2. 抜粋 2:www.cve.org
    [{"product":"Divi Form Builder","range":"<= 5.1.8"}]
    この抜粋の出典を開く

    取得元の項目:/affected / 言語:und

  3. 抜粋 3:www.cve.org
    [{"vendor":"Divi Engine","product":"Divi Form Builder","defaultStatus":"unaffected","versions":[{"version":"0","lessThanOrEqual":"5.1.8","versionType":"semver","status":"affected"}]}]
    この抜粋の出典を開く

    取得元の項目:/affectedDetails / 言語:und

  4. 抜粋 4:www.cve.org
    CVE-2026-5524
    この抜粋の出典を開く

    取得元の項目:/recordId / 言語:und

悪用状況の「未確認」は、悪用されていないことを意味しません。対策は製品・バージョン・利用条件によって異なります。適用前に情報源とご自身の環境を確認してください。

情報の出典と更新日時

CVSS評価元:security@wordfence.com。重要度は技術的な深刻度の目安であり、対応の順序は悪用状況や利用環境も含めて判断してください。

情報源ごとの取得日時

原典の更新日時と当サイトの取得日時は、情報源ごとに異なります。上の更新・取得日時は、それぞれの最新値です。

  • NVD原典の更新:2026/10/26 06:10 JST取得:2026/10/28 03:57 JST
原文と条件を確認

The Divi Form Builder plugin for WordPress is vulnerable to Arbitrary File Upload leading to Remote Code Execution in all versions up to and including 5.1.8. This is due to insufficient file extension validation in the do_image_upload() function where user-supplied input from the acceptFileTypes POST parameter is directly interpolated into a regular expression used to validate uploaded files. Attackers can specify PHP-executable extensions such as .phtml, .phar, .php5, or .php7 to bypass the plugin's .htaccess protection which only blocks .php files specifically. Additionally, on Nginx-based servers, the .htaccess protection is completely ineffective as Nginx does not process .htaccess files. This makes it possible for unauthenticated attackers (who can obtain a nonce from any public page containing a form) to upload executable PHP files to the publicly accessible /wp-content/uploads/de_fb_uploads/ directory and achieve Remote Code Execution by accessing the uploaded file via HTTP. The vulnerability was partially patched in version 5.1.3.

この情報をAIに渡す

この1件の対象・リスク・対策・出典を取得

JSONを見る

このサービスを共有

脆弱性を確認する入口を、チームや知り合いに。

Xで共有